// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(COT|MED)[AB]?-?[\dJK]{1,8}(\s+D{1,3})?\b").unwrap();
let string = "MED-125
COTA-1224
MED4
COTB-892K777
MED-33 DDD
MED-12J44445
MED-234J5672
COT-11161K11111111111111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}