$re = '/(COT|MED)[AB]?-?[\dJK]{1,8}(\s+D{1,3})?\b/m';
$str = 'MED-125
COTA-1224
MED4
COTB-892K777
MED-33 DDD
MED-12J44445
MED-234J5672
COT-11161K11111111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);