#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(t(?:\w{4})\d{3})\b"
Local $sString = "SELECT tcmcs003.*, tccom130.nama, tccom705.dsca, tcmcs052.dsca, tccom100.nama " & @CRLF & _
"FROM tcmcs003, tccom130,tccom705,tcmcs052,tccom100 " & @CRLF & _
"WHERE tcmcs003.cadr REFERS TO tccom130 " & @CRLF & _
" AND tcmcs003.casi REFERS TO tccom705 " & @CRLF & _
" AND tcmcs003.cprj REFERS TO tcmcs052 " & @CRLF & _
" AND tcmcs003.bpid REFERS TO tccom100 " & @CRLF & _
"ORDER BY tcmcs003._index1"
Local $sSubst = "$1XXX"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)