import re
regex = re.compile(r"\b(t(?:\w{4})\d{3})\b")
test_str = ("SELECT tcmcs003.*, tccom130.nama, tccom705.dsca, tcmcs052.dsca, tccom100.nama \n"
"FROM tcmcs003, tccom130,tccom705,tcmcs052,tccom100 \n"
"WHERE tcmcs003.cadr REFERS TO tccom130 \n"
" AND tcmcs003.casi REFERS TO tccom705 \n"
" AND tcmcs003.cprj REFERS TO tcmcs052 \n"
" AND tcmcs003.bpid REFERS TO tccom100 \n"
"ORDER BY tcmcs003._index1")
subst = "$1XXX"
result = regex.sub(subst, test_str)
if result:
print(result)