using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![/*])[^/* ]@import ['""](.*?)['""]";
string input = @"//@import ""/my/path2""
/*@import ""/my/path1"" */
@import ""/my/path3""
@import ""/my/path4""
@import ""/my/path5""
/* @import ""/my/path5"" */";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}