import Foundation
let pattern = #"(?![/*])[^/* ]@import ['"](.*?)['"]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
//@import "/my/path2"
/*@import "/my/path1" */
@import "/my/path3"
@import "/my/path4"
@import "/my/path5"
/* @import "/my/path5" */
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)