import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![/*])[^/* ]@import ['\"](.*?)['\"]";
final String string = "//@import \"/my/path2\"\n"
+ "/*@import \"/my/path1\" */\n"
+ "@import \"/my/path3\"\n"
+ "@import \"/my/path4\"\n"
+ "@import \"/my/path5\"\n"
+ "/* @import \"/my/path5\" */";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}