using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([A-Z]+)[-_])?(\w+.SV)$";
string input = @"TRND-0LL2134.SV
TRN_RTXDFT.SV
TRND_ZRSFTFF.SV
DR3345.SV";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}