import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([A-Z]+)[-_])?(\\w+.SV)$";
final String string = "TRND-0LL2134.SV\n"
+ "TRN_RTXDFT.SV\n"
+ "TRND_ZRSFTFF.SV\n"
+ "DR3345.SV";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}