re = /^(([A-Z]+)[-_])?(\w+.SV)$/m
str = 'TRND-0LL2134.SV
TRN_RTXDFT.SV
TRND_ZRSFTFF.SV
DR3345.SV'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end