#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "m!\A[][:\p{Ll}\p{Lu}\p{Zs}\p{Nd}]\[error\][][.\p{Ll}\p{Zs}\p{Nd}]ModSecurity:[]MS_[".\/\p{Ll}\p{Zs}\p{Nd}-]\[id "9990229"\][]MS_[".\/\p{Ll}\p{Zs}\p{Nd}-]$!mg) {" & @CRLF & _
"}" & @CRLF & _
""
Local $sString = "[Tue Nov 04 20:49:49 2014] [error] [client 72.253.126.112] ModSecurity: [file "/etc/httpd/modsecurity-crs/custom_Mod_Security_rules/srb_block_login_attempts.conf"] [line "11"] [id "9990229"] [msg "Bad url - blogs"] [severity "CRITICAL"] Access denied with code 403 (phase 2). Pattern match "/blogs/" at REQUEST_URI. [hostname "mauicom.com"] [uri "/blogs/"] [unique_id "VFnIjUj9fm8AAI64MP4AAAAG"]" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)