# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"m!\A[][:\p{Ll}\p{Lu}\p{Zs}\p{Nd}]\[error\][][.\p{Ll}\p{Zs}\p{Nd}]ModSecurity:[]MS_[\".\/\p{Ll}\p{Zs}\p{Nd}-]\[id \"9990229\"\][]MS_[\".\/\p{Ll}\p{Zs}\p{Nd}-]$!mg) {\n"
r"}\n")
test_str = ("[Tue Nov 04 20:49:49 2014] [error] [client 72.253.126.112] ModSecurity: [file \"/etc/httpd/modsecurity-crs/custom_Mod_Security_rules/srb_block_login_attempts.conf\"] [line \"11\"] [id \"9990229\"] [msg \"Bad url - blogs\"] [severity \"CRITICAL\"] Access denied with code 403 (phase 2). Pattern match \"/blogs/\" at REQUEST_URI. [hostname \"mauicom.com\"] [uri \"/blogs/\"] [unique_id \"VFnIjUj9fm8AAI64MP4AAAAG\"]\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.