// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"m!\A[][:\p{Ll}\p{Lu}\p{Zs}\p{Nd}]\[error\][][.\p{Ll}\p{Zs}\p{Nd}]ModSecurity:[]MS_[".\/\p{Ll}\p{Zs}\p{Nd}-]\[id "9990229"\][]MS_[".\/\p{Ll}\p{Zs}\p{Nd}-]$!mg) {
}
"#).unwrap();
let string = "[Tue Nov 04 20:49:49 2014] [error] [client 72.253.126.112] ModSecurity: [file \"/etc/httpd/modsecurity-crs/custom_Mod_Security_rules/srb_block_login_attempts.conf\"] [line \"11\"] [id \"9990229\"] [msg \"Bad url - blogs\"] [severity \"CRITICAL\"] Access denied with code 403 (phase 2). Pattern match \"/blogs/\" at REQUEST_URI. [hostname \"mauicom.com\"] [uri \"/blogs/\"] [unique_id \"VFnIjUj9fm8AAI64MP4AAAAG\"]
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}