import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "m!\\A[][:\\p{Ll}\\p{Lu}\\p{Zs}\\p{Nd}]\\[error\\][][.\\p{Ll}\\p{Zs}\\p{Nd}]ModSecurity:[]MS_[\".\\/\\p{Ll}\\p{Zs}\\p{Nd}-]\\[id \"9990229\"\\][]MS_[\".\\/\\p{Ll}\\p{Zs}\\p{Nd}-]$!mg) \\{\n"
+ "\\}\n";
final String string = "[Tue Nov 04 20:49:49 2014] [error] [client 72.253.126.112] ModSecurity: [file \"/etc/httpd/modsecurity-crs/custom_Mod_Security_rules/srb_block_login_attempts.conf\"] [line \"11\"] [id \"9990229\"] [msg \"Bad url - blogs\"] [severity \"CRITICAL\"] Access denied with code 403 (phase 2). Pattern match \"/blogs/\" at REQUEST_URI. [hostname \"mauicom.com\"] [uri \"/blogs/\"] [unique_id \"VFnIjUj9fm8AAI64MP4AAAAG\"]\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}