using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=.com\\)[^\\]*(?=\\))";
string input = @"SERVERNAME2018-03-08 18:40:28 File: ""x:\_default\app.address.com\MedSoftware\.data\BackEnd.Technical.Dictionaries.Service-180308182311\Web.config"", Name: ""dictionaries_data_product"", CS: ""###connectionStrings.dictionariesdataproduct.connectionString"" info: Format of the initialization string does not conform to specification starting at index 0. 6069
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}