re = /((?<=.com\\)[^\\]*(?=\\))/
str = 'SERVERNAME2018-03-08 18:40:28 File: "x:\\_default\\app.address.com\\MedSoftware\\.data\\BackEnd.Technical.Dictionaries.Service-180308182311\\Web.config", Name: "dictionaries_data_product", CS: "###connectionStrings.dictionariesdataproduct.connectionString" info: Format of the initialization string does not conform to specification starting at index 0. 6069
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end