# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<=.com\\)[^\\]*(?=\\))"
test_str = ("SERVERNAME2018-03-08 18:40:28 File: \"x:\\_default\\app.address.com\\MedSoftware\\.data\\BackEnd.Technical.Dictionaries.Service-180308182311\\Web.config\", Name: \"dictionaries_data_product\", CS: \"###connectionStrings.dictionariesdataproduct.connectionString\" info: Format of the initialization string does not conform to specification starting at index 0. 6069\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.