#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)^\s*Param\(.*?\)$"
Local $sString = "Param(" & @CRLF & _
" [Parameter(Mandatory)]" & @CRLF & _
" [String]$TaskName," & @CRLF & _
" [Switch]$Debug = $false" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"# Debug" & @CRLF & _
"if ($Debug)" & @CRLF & _
"" & @CRLF & _
"Param(...)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)