package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)^\s*Param\(.*?\)$`)
var str = `Param(
[Parameter(Mandatory)]
[String]$TaskName,
[Switch]$Debug = $false
)
# Debug
if ($Debug)
Param(...)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}