re = /(?s)^\s*Param\(.*?\)$/m
str = 'Param(
[Parameter(Mandatory)]
[String]$TaskName,
[Switch]$Debug = $false
)
# Debug
if ($Debug)
Param(...)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result