import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^\\s*Param\\(.*?\\)$";
final String string = "Param(\n"
+ " [Parameter(Mandatory)]\n"
+ " [String]$TaskName,\n"
+ " [Switch]$Debug = $false\n"
+ ")\n\n"
+ "# Debug\n"
+ "if ($Debug)\n\n"
+ "Param(...)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}