using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";"">\S+\s*(.*?)(?=\s*<br>)";
string input = @"<td title=""Click to view the details"" class=""alignLeft genericName padding2"" style=""cursor: pointer;"">ACETYLCYSTEINE 200MG/ ML INJ <br>COLORLESS (IJ)</td>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}