re = /;">\S+\s*(.*?)(?=\s*<br>)/m
str = '<td title="Click to view the details" class="alignLeft genericName padding2" style="cursor: pointer;">ACETYLCYSTEINE 200MG/ ML INJ <br>COLORLESS (IJ)</td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end