const regex = new RegExp(';">\\S+\\s*(.*?)(?=\\s*<br>)', 'gm')
const str = `<td title="Click to view the details" class="alignLeft genericName padding2" style="cursor: pointer;">ACETYLCYSTEINE 200MG/ ML INJ <br>COLORLESS (IJ)</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}