import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ";\">\\S+\\s*(.*?)(?=\\s*<br>)";
final String string = "<td title=\"Click to view the details\" class=\"alignLeft genericName padding2\" style=\"cursor: pointer;\">ACETYLCYSTEINE 200MG/ ML INJ <br>COLORLESS (IJ)</td>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}