using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(#[\S]+)";
string input = @"گویند کسان #بهشت با #حور خوش است and I tell them that #paradise is good with #wine or اینقد بگیر #مست شو it was my #advice and you should #за сказать";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}