import re
regex = re.compile(r"(#[\S]+)", flags=re.IGNORECASE)
test_str = "گویند کسان #بهشت با #حور خوش است and I tell them that #paradise is good with #wine or اینقد بگیر #مست شو it was my #advice and you should #за сказать"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")