// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(#[\S]+)").unwrap();
let string = "گویند کسان #بهشت با #حور خوش است and I tell them that #paradise is good with #wine or اینقد بگیر #مست شو it was my #advice and you should #за сказать";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}