const regex = /(#[\S]+)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(#[\\S]+)', 'ig')
const str = `گویند کسان #بهشت با #حور خوش است and I tell them that #paradise is good with #wine or اینقد بگیر #مست شو it was my #advice and you should #за сказать`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}