#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "var1="(.*?)".*?\n*.*?var2="(.*?)".*?\n*.*?var3="(.*?)""
Local $sString = "<span var1="abc" some random thing var2="cde" another random stuff var3="efg"></span>" & @CRLF & _
"<span var1="abc" some random thing var2="cde" another random stuff??>" & @CRLF & _
"<::" var3="efg"></span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")