$re = '/var1="(.*?)".*?\n*.*?var2="(.*?)".*?\n*.*?var3="(.*?)"/';
$str = '<span var1="abc" some random thing var2="cde" another random stuff var3="efg"></span>
<span var1="abc" some random thing var2="cde" another random stuff??>
<::" var3="efg"></span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);