using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"var1=""(.*?)"".*?\n*.*?var2=""(.*?)"".*?\n*.*?var3=""(.*?)""";
string input = @"<span var1=""abc"" some random thing var2=""cde"" another random stuff var3=""efg""></span>
<span var1=""abc"" some random thing var2=""cde"" another random stuff??>
<::"" var3=""efg""></span>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}