const regex = /var1="(.*?)".*?\n*.*?var2="(.*?)".*?\n*.*?var3="(.*?)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('var1="(.*?)".*?\\n*.*?var2="(.*?)".*?\\n*.*?var3="(.*?)"', 'g')
const str = `<span var1="abc" some random thing var2="cde" another random stuff var3="efg"></span>
<span var1="abc" some random thing var2="cde" another random stuff??>
<::" var3="efg"></span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}