use strict;
my $str = 'chedilpakkam, tiruvallur,chedilpakkam, tiruvallur
ch edilpakkam,tiruvallur, chedilpakkam,tiruvallur
ch edilpakkam,tiruvallur, chedilpakkam,tiruvallur
chedilpakkam, tiruvallur,chedilpakkam, tiruvallur
';
my $regex = qr/(?<!^)\b(\w)/mp;
my $subst = '($1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";