#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\b\w+[\w\s]+\b)(?:.*?\b\1)"
Local $sString = "The name is Anthony is is The name is Anthony" & @CRLF & _
"India is my country All Indians are India is my country" & @CRLF & _
"Times of India Alphabet Google is the company Alphabet Google canteen" & @CRLF & _
"boi is oi"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")