const regex = /(\b\w+[\w\s]+\b)(?:.*?\b\1)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\w+[\\w\\s]+\\b)(?:.*?\\b\\1)', 'g')
const str = `The name is Anthony is is The name is Anthony
India is my country All Indians are India is my country
Times of India Alphabet Google is the company Alphabet Google canteen
boi is oi`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}