$re = '/(\b\w+[\w\s]+\b)(?:.*?\b\1)/';
$str = 'The name is Anthony is is The name is Anthony
India is my country All Indians are India is my country
Times of India Alphabet Google is the company Alphabet Google canteen
boi is oi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);