import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td.*?<a.*? title\\s*=\\s*\"([^\"]+).*?</td>";
final String string = "<td><a href=\"/wiki/Wal-Mart_Stores,_Inc.\" title=\"Wal-Mart Stores, Inc.\"class=\"mw-redirect\">Wal-Mart Stores, Inc.</a></td>\n"
+ "<td style=\"background: #ffffcc;\"><a href=\"/wiki/Sinopec_Group\" title=\"Sinopec Group\" class=\"mw-redirect\">Sinopec Group</a></td>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}