import re
regex = re.compile(r"<td.*?<a.*? title\s*=\s*\"([^\"]+).*?</td>", flags=re.MULTILINE)
test_str = ("<td><a href=\"/wiki/Wal-Mart_Stores,_Inc.\" title=\"Wal-Mart Stores, Inc.\"class=\"mw-redirect\">Wal-Mart Stores, Inc.</a></td>\n"
"<td style=\"background: #ffffcc;\"><a href=\"/wiki/Sinopec_Group\" title=\"Sinopec Group\" class=\"mw-redirect\">Sinopec Group</a></td>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")