// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<td.*?<a.*? title\s*=\s*"([^"]+).*?</td>"#).unwrap();
let string = "<td><a href=\"/wiki/Wal-Mart_Stores,_Inc.\" title=\"Wal-Mart Stores, Inc.\"class=\"mw-redirect\">Wal-Mart Stores, Inc.</a></td>
<td style=\"background: #ffffcc;\"><a href=\"/wiki/Sinopec_Group\" title=\"Sinopec Group\" class=\"mw-redirect\">Sinopec Group</a></td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}