re = /<td.*?<a.*? title\s*=\s*"([^"]+).*?<\/td>/m
str = '<td><a href="/wiki/Wal-Mart_Stores,_Inc." title="Wal-Mart Stores, Inc."class="mw-redirect">Wal-Mart Stores, Inc.</a></td>
<td style="background: #ffffcc;"><a href="/wiki/Sinopec_Group" title="Sinopec Group" class="mw-redirect">Sinopec Group</a></td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end