use strict;
my $str = '23000,20
23000,30
1300,20
100
161,43256
23123000,20';
my $regex = qr/[,.]/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";