package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((0?\d{1,2})|(1[0-7]\d)|(180))°(([0-5]?\d)|(60)),(([0-5]?\d)|(60))[EO]$`)
var str = `180°59,54O`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}