import Foundation
let pattern = #"^((0?\d{1,2})|(1[0-7]\d)|(180))°(([0-5]?\d)|(60)),(([0-5]?\d)|(60))[EO]$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"180°59,54O"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)