const regex = /^((0?\d{1,2})|(1[0-7]\d)|(180))°(([0-5]?\d)|(60)),(([0-5]?\d)|(60))[EO]$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((0?\\d{1,2})|(1[0-7]\\d)|(180))°(([0-5]?\\d)|(60)),(([0-5]?\\d)|(60))[EO]$', 'g')
const str = `180°59,54O`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}