import re
regex = re.compile(r"^((0?\d{1,2})|(1[0-7]\d)|(180))°(([0-5]?\d)|(60)),(([0-5]?\d)|(60))[EO]$")
test_str = "180°59,54O"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")