using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bOIL CHANGE REQUEST V3\b .*\s.*)";
string input = @"<testerconfirmation title=""Tester Confirmation "" passedbutton=""yes"" timeoutresult=""failed"">REQUIREMENT SPECTED
After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V3 must be activated according to indications characteristics during 5 seconds.
Press YES to continue.</testerconfirmation>
<testerconfirmation title=""Tester Confirmation "" passedbutton=""yes"" timeoutresult=""failed"">REQUIREMENT SPECTED
After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V1 must be activated according to indications characteristics during 5 seconds.
Press YES to continue.</testerconfirmation>
<testerconfirmation title=""Tester Confirmation "" passedbutton=""yes"" timeoutresult=""failed"">REQUIREMENT SPECTED
After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V2 must be activated according to indications characteristics during 5 seconds.
Press YES to continue.</testerconfirmation>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}