# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\bOIL CHANGE REQUEST V3\b .*\s.*)"
test_str = ("<testerconfirmation title=\"Tester Confirmation \" passedbutton=\"yes\" timeoutresult=\"failed\">REQUIREMENT SPECTED\n"
"After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V3 must be activated according to indications characteristics during 5 seconds.\n"
"Press YES to continue.</testerconfirmation>\n"
"<testerconfirmation title=\"Tester Confirmation \" passedbutton=\"yes\" timeoutresult=\"failed\">REQUIREMENT SPECTED\n"
"After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V1 must be activated according to indications characteristics during 5 seconds.\n"
"Press YES to continue.</testerconfirmation>\n"
"<testerconfirmation title=\"Tester Confirmation \" passedbutton=\"yes\" timeoutresult=\"failed\">REQUIREMENT SPECTED\n"
"After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V2 must be activated according to indications characteristics during 5 seconds.\n"
"Press YES to continue.</testerconfirmation>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.