import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bOIL CHANGE REQUEST V3\\b .*\\s.*)";
final String string = "<testerconfirmation title=\"Tester Confirmation \" passedbutton=\"yes\" timeoutresult=\"failed\">REQUIREMENT SPECTED\n"
+ "After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V3 must be activated according to indications characteristics during 5 seconds.\n"
+ "Press YES to continue.</testerconfirmation>\n"
+ "<testerconfirmation title=\"Tester Confirmation \" passedbutton=\"yes\" timeoutresult=\"failed\">REQUIREMENT SPECTED\n"
+ "After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V1 must be activated according to indications characteristics during 5 seconds.\n"
+ "Press YES to continue.</testerconfirmation>\n"
+ "<testerconfirmation title=\"Tester Confirmation \" passedbutton=\"yes\" timeoutresult=\"failed\">REQUIREMENT SPECTED\n"
+ "After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V2 must be activated according to indications characteristics during 5 seconds.\n"
+ "Press YES to continue.</testerconfirmation>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}