using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\s][\d])(.*?)(?=[\d])";
string input = @"blah xzuyguhbc ibcbb bqw 2 extract1 ☺️ jbjhcb 6 extract2 ? bjvcvvv
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}